Unable to find or reset password

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Chrome 97.0.4692.99, MacOS Catalina 10.15.7,

Memex GO, iOS 14.3

  1. Which version of Memex are you running?
    Jan 28 version 3.1.3

  2. What are the steps you took that lead to the bug?
    Go to dashboard, account. OR on mobile, logged out, fill in username and password, click on forgot password?

I’ve tried several ways to reset my password so I can enable Memex GO on an additional device. The option is nowhere to be found. I already tried sending a chat and entered a message in the airtable form, but no answer there. This problem is really holding me back from getting a Pioneer plan.

Hey Dave!

Sorry for the troubles.
The password reset mechanism you can find when you log out of the extension, then log in again and on the password field there is a button “Forgot Password”.
Do you find it there?

I’ll push an update later today adding the button more prominently without the need to log out, thanks for the pointer!

Thanks for the swift reply! I haven’t tried logging out as I didn’t want to risk losing access to my account. Your solution will be a perfect answer.

I pushed an update in 3.1.8 where you can reset your password when still being logged in.
This is already available in Firefox and Chrome.

Just finished the work to also add this (and a larger redesign) to the mobile app.
Will go live in the next days.