Tags syncing problem

Which browser, operating system and versions of those are you using?

OS

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.6 LTS
Release:	18.04
Codename:	bionic

Chrome

$ google-chrome --version
Google Chrome 95.0.4638.69 
WorldBrain's Memex extension version 3.0.5

Firefox

$ firefox -v
Mozilla Firefox 93.0
WorldBrain's Memex extension version 3.0.5

What are the steps you took that lead to the bug?

When I saw add-on update on Firefox I start cloud sync.

Result - pages synced successfully, but tags for a few pages not copied to Firefox.

After what I tried to create and delete tags in both browsers. Looks like only Firefox -> Chrome sync for tags working as expected.

Link to screen record - https://www.dropbox.com/s/73dcvh51ubuqvdi/out.ogv?dl=0

Thanks a lot for this detailed bug report. I’ll put it on the high priority list of things to investigate and fix.

I tried to reproduce it but failed to do so, so I need ab it more information.
When did you install Memex on Chrome and Firefox respectively? Before or after the new sync launched? (which was beginning of October 13)

Can you send me the url or a couple of the, where it failed to sync properly?

Both before the new sync launched

Timeline:

  • Chrome extension installed
  • Firefox add-on installed
  • New sync launched
  • Chrome synced
  • Firefox synced

Can you send me the url…

Update - right now I see all tags in place and can’t reproduce this bug too.