Send to Memex missing on Android

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Android 12. Browsers tried are Firefox, Brave, Kiwi, and Chrome, but the share menu isn’t tied to the source application in Android.

  2. Which version of Memex are you running?
    Memex Go 1.8.0

  3. What are the steps you took that lead to the bug?
    Install Memex Go, sync with an existing account that already contains content, wait for Sync to complete without switch apps or turning off the screen (not doing this causes other invisible errors after the fact). Open a browser and navigate to any website. Touch the share button in the browser. Notice Memex Go is not in the list of options.

In Android, apps have to register for what they can handle. It seems likely the Memex Go app isn’t properly registered to have URLs shared to it. Android 12 became much more strict about this actually being required, while previous versions often showed almost every app on the system registered to allow sharing anything with it. I would guess this is an existing bug that an app requirement was never properly implemented, and now the OS enforcement of compliance is breaking it.

EDIT: typos

Thanks for the report!

Will be tackled immediately next week.

We did an investigation on this today and it seems that it should just work.

A couple of questions:

  • what particular device or OEM are you running?
  • did it work before? If so, what was the device details then?

I’m using an International/Unlocked Samsung Galaxy S21 Ultra with stock OEM firmware and not rooted.

I am a relatively new user, so I only recently even tried this before migrating fully, and it didn’t work even the first time for me.
I did see there’s brittleness about the first time sync in Memex Go, if you do navigate away during the first sync it will appear to have worked to get your data, but won’t detect that you’re logged in. I wiped all data for the app when that happened the first time, uninstalled it, and re-installed it, then actually waited with the screen on for the entire 10 minute sync of my 200 bookmarks without any notes or highlights. The login state was property detected then.

I installed Memex Go from the Play Store, and as I mentioned I’ve tried sharing a website from many different browsers. I can see and open things fine from Memex Go, but I’ve yet to find any app that I can share to Memex Go from.

EDIT: If there’s some sort of bug reporting mechanism within Memex Go you’d like me to use to send logs, I’m more than happy to. I just don’t see anything obvious.

It just started showing up correctly now, possibly after an unrelated reboot of my device. I guess I should have thought of rebooting my phone, which seems to be an arbitrary solution for various problems, but regardless it’s working as expected now.

For future debugging, key things to try:
Wipe all app data for the app, open it again, log in again, and make absolutely sure you keep the screen on and don’t do anything else with your phone while it’s syncing. If you get oddities other than the app thinking you’re not logged in after that, reboot your phone and try again.

Thanks for trying it out, I was just coming off a friend’s phone and there it was working. So I was about to reply for more info, but glad its working for you now.

We just pushed a version to the Android store where the sync screen is kept open automatically too, thanks for the pointer. It was working like that in an earlier version with the old sync.

Also we fixed 2 other bugs with that version:

With 1.8.5 we implemented a function that blocks the screen from turning off while the sync runs.
Next also improving the way it will pick up the sync again when you navigate away.

I just finished a larger redesign of the mobile app and now we can tackle these improvement better.
Will go out this week.

So is m memex go not working?