PDF Reader now bugged?

Hey, it seems the PDF reader stopped working? I’m not doing anything different and it was fine two days ago. I’ve tried random pdfs on google and some of my web pdfs, but they aren’t loading. To load them I have to disable the Memex PDF reader or load them on a browser without Memex installed. I’ve tried on the latest versions of Brave, Chrome, and Firefox with Memex 3.0.

We’re running into a very weird bug and are already in the process of investigating and fixing it.
We were extensively testing a fix that we did to get the new PDF viewer approved for Firefox and both in staging and production tests they worked.

Fix will go out today or tomorrow.

1 Like

Fix is out and should be available on Firefox in the next 2-3 hours and on Chrome in the next days (they have now also some congestions in their review pipeline)

1 Like

What is the best way to disable Memex pdf reader? I don’t see it in settings.

Open a pdf first, then click extension button and toggle the pdf reader off. It’ll be disabled afterwards on any new tabs.

1 Like

Fix to PDF bug now in 3.0.4 available on Chrom(ium) browsers and Firefox.

Thank you!! :slight_smile:

I’m noticing now the highlighter is a bit bugged, it’s not highlighting my exact selection (just pdfs, it works fine on other webpages). The highlight it gives me begins and ends at several words before my actual selection. Tested on Chrome, Brave, Firefox.

PDFs are a hell to work with. Will have to look into how to fix it. Put it on the things to prioritise and fix!

I would like to disable pdf reader on firefox… how may I do that? (I prefer to download pdf when I click on them)

Hello, I experienced an issue after trying to export to PDF a Google Analytics report (from within Google Analytics). However instead of the PDF opening for download, Memex opened and I received this error message:

"The PDF could not be found in the expected location [if you have a copy somewhere else, open it with this browser or drop here].

I also got shut out of Google Analytics. I retried exporting a PDF several times with same outcome… I saw the comments here about toggling PDF on/off and checked that. I also logged out of the browser (Firefox 97) but that didn’t work. I then restarted by machine (Windows). In the end I had to log into Edge which doesn’t have Memex installed.

Would appreciate you looking into this - thanks :slight_smile:

This is still buggy for me. Memex tries to open the pdf but says it isn’t in the location it expected / can’t be found.

On firefox 100.0.2