No initial Memex Go setup

I have a dual setup (mobile and laptop) and want to sync my Android device with my laptop. Both have
Memex installed and are connected to the same Wi-Fi network. But still it doesn’t work.

What are the steps to reproduce the issue?

  1. Open Memex Dashboard on the computer
  2. Pair a new device
  3. Scan QR-code with mobile phone
  4. Waiting…
  5. ‘Time-out’ error OR ‘ICE-connection’ failed

What browser and operating system are you using?
Windows 10 x64 (update 1909), Firefox 73.0.1 (64-bit)

Possible relevant debug messages:
sendRemoveListener on closed conduit
webrtc.peerconnection.promise_stats_used - Unknown scalar.
The Notification permission may only be requested from inside a short running user-generated event handler.
Error: cannot signal after peer is destroyed
@firebase/database: FIREBASE WARNING: Exception was thrown by user callback. d@moz-extension://87413c4a-1991-44e1-ba0e-9739116205b0/background.js:1:2806302

Hey @Dpolder!

Sometimes the problem is that your WIFI blocks the WebRTC connection.
Try changing it. In such cases what usually works for me is using your phone’s tethering.

We already have on the roadmap to make the WebRTC connection more reliable, as it will be used a lot more in the future.

Hey @BlackForestBoi

Thanks for responding so quickly.
I already tried the solution you provided, but despite using this,
it still gives the same error or timeout as before.

Is it possible to synchronize without WebRTC or do you have another solution?

We don’t have any other way of syncing your phone as of now unfortunately.
Do you have any other extensions or ad/scriptblockers enabled that could interfere with setting up a connection?

When you say you tried the solution provided, do you mean changing the WIFI or tethering from your phone?