No highlights, captures etc. loading -- indicator ring turning forever (Firefox, Win10)

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Firefox 115.0.2 (64-Bit); Windows 10 22H2

  2. Which version of Memex are you running?

  3. What are the steps you took that lead to the bug?
    When I click on the Memex icon, the “now loading” indicator circle/ring turns forever, never loading anything. The same happens when I go to the dashboard and try to access anything I have captured, annotated, highlighted etc. over the last years. All my data should be stored locally, since I never signed up for any memex account.
    I wasn’t sure if my data was somehow corrupted and thought about restoring an older backup – which isn’t possible, as the backup page shows the same forever loading behavior.

Any ideas?
Thanks and all the best

just updated to Memex-Addon v. 3.4.22 but the problem is still the same :confused:
forever this:

Hey there,
sorry for bumping this thread, but my problem still persists and I really need these annotations and highlights I collected for an academic research project over the last years :see_no_evil: Should I try to delete and re-install the browser add-on? Is this safe or could I lose all my (locally stored) data in the process?

Best regards

Hey there,

so sorry for not having seen this.
Can you try to install the extension in another profile, or browser, and then sign in with your existing credentials?

That should in any case pull everything down to that new extension.

But apart from that usually what helps is disabling and re-enabling the extensions via about://addons
Does that not help?

If that still does not work lets hop on a quick call to make it work for you.


thanks a lot for your reply!

I tried your proposed solutions which yielded the following results:

First, I de- and re-activated the addon, which didn’t change anything – did it again and restarted my browser in between the de- and re-activation but it’s still the same.

Second, I created a new profile in my browser, installed the addon there and voilá: The addon works, but it doesn’t load my content. I visit the same website in both profiles, press Alt+Q to open the Memex sidebar and it opens in the new profile but not in the old one. Same goes for the Memex button-overlay that appears upon selecting text in the new profile but not the old one.

Which leads me to the last part of your solution that I can not complete, that is: logging into my Memex account, because I never created one if I remember correctly. Am I mistaken, or wasn’t it, for a long time, possible to use Memex without an account as all the data was stored locally anyway? I even believe that I was drawn to Memex in the first place, because it didn’t require signing up for anything :sweat_smile:

Is this the problem at the base of it all, that I missed an update’s info that I now need an account? :see_no_evil: I was even googling for such an info a while back, but couldn’t really find anything.
And why, then, can I use Memex in the new profile without an account?

Should I create an account from the addon installed in my old browser profile that has all my highlights stored locally, or will this overwrite my data? Or should I simply re-install the plugin in my old/existing profile? Would this endanger my locally stored highlights/data?

Thanks and all the best!

Sorry to bump this again, but do you have any suggestions? Can I create an account and log in without losing my old profile that was never registered with the memex servers, in order to enable loading this profile’s content in the browser plugin again?