Memex not recording, backup not working

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Brave [Version 1.15.72 Chromium: 86.0.4240.75 (Official Build) (x86_64)]
  2. Which version of Memex are you running?
    2.7.3 Beta
  3. What are the steps you took that lead to the bug?
    Just trying to use it. It’s now dead and I can’t trust it at all.
    New page seemed to show new history for a while but was empty this morning after a restart. Dashboard list shows only items restored from backup taken before installing Beta. Had to remove and re-install to get Beta installed. Restore worked on the second or third try. Now backup page clears screen and puts up progress wheel - hung forever (24 hours at least).

I am also having the same issue. It is not recording any of my activity.
I’m using Firefox v81.0.1. Memex v2.7.3

Except something I have added to the collection it is not recording anything at all. I tried a reinstall, but still no activity recorded. My dashboard is just empty!

Seeing that smiley just makes me sad.

(Also when I uninstall and reinstall it, it doesn’t feel like a fresh install. My preferences are saved from the last install I think.)

1 Like


To copy the notes from our conversation from slack:
There may be something you can try in the mean time:
Go to brave://Extensions > enable developer mode > memex > details > background page and then try to find this.What you need to do:

  1. if there is an item like the one highlighted in my screenshot, select and delete it via the little X (but only after you made the screenshot)
  2. Go back to the backup screen and see if its now working.

1 Like


The extension only does indexing on pages you actively bookmark (via browser, memex menu or keyboardshortcuts), annotate, tag or put in a list. We recently disabled the history search.

Yeah Firefox keeps the data between installs. Weird flex. Not ok.

And the solution above did fix issue.