Local backup not working

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Chrome ,Version 94.0.4606.71
  2. Which version of Memex are you running?
    current on Chrome store 2.19.2
  3. What are the steps you took that lead to the bug?

Backup Helper Version: 0.5.4
OS: Mac Catalina 10.15.7(19H1419)

I’m follow the Tutorials to set backup
Backup to Google Drive or locally to any cloud provider

I backup recently, I want to restore from my backup ,but when I go to “Restore & Replace” > the imfomation was show below:
Important: To restore, pick the parent folder of ‘/backup’

To your local hard drive

and the alert continue to showing that I need to download memex-backup-helper,but I already download and install before

so I reinstall chrome extension, reinstall memex-backup-helper, problem still occurred.

I open the browser DevTool ,there show lots of errors, I notice when I click I’m Ready button, an error log showing

options.js:1266 GET https://localhost:11922/status net::ERR_SSL_PROTOCOL_ERROR

than I use curl tool to try ssl issue , the log showing below

curl https://localhost:11922/status  -vvv -kvL                                                                 1 ↵
*   Trying ::1...
* TCP_NODELAY set
* Connection failed
* connect to ::1 port 11922 failed: Connection refused
*   Trying 127.0.0.1...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 11922 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number
* Closing connection 0
curl: (35) error:1400410B:SSL routines:CONNECT_CR_SRVR_HELLO:wrong version number

telnet to test connection is ok

telnet 127.0.0.1 11922                                                                                        35 ↵
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
test
HTTP/1.1 400 Bad Request
Connection: close

Connection closed by foreign host.

I don’t know the root cause is, maybe localhost ssl issue?