Known issues with the new sync

Here is a list of known issues with the sync as of October 13, 2021:

Critical

  • Bug: Existing users upgrading are missing the full-text being synced over to the new devices. Already working on a fix and it is retrospectively possible to upload those again. The only thing that won’t work for now is to full-text search for pages on other synced browsers that you’ve saved in the past. All new ones work and titles work also for old pages.

Priority 1

  • Feature: Full Text (and sometimes title) currently not indexed for pages coming from a mobile device. Possible to fix retrospectively.

Priority 2

  • Interface: Sync Counter and time stamp off sometimes. Often corrected by reloading the tab, or quickly turning the extension off and on via chrome://extensions

Priority 3:

  • Interface: When you start syncing with a lot of saved pages, the counter seemingly doesn’t go down or you see the number twitching around because of the way it counts full-text documents and favicons associated with the pages. As soon as it worked through the list of pages to sync, it’ll start going down normally. If you wanna make sure the sync runs go to chrome://extension > memex > background page > network to see that stuff is uploaded (on Firefox start with about:addons > debug addons > memex > inspect)

Howdy! Had a kind of choppy experience with Sync mode, thought I would post here for advice before moving forward.

I saw the update arrive (ungoogled-chromium via the ungoogled-chromium-store plugin). I installed it, then didn’t think about it or use it for ~4-6 hours. Then I tried to bookmark a page. This is basically what I do with Memex. I have ~20 tags, ~10 collections, ~1000’s of pages (but nothing well organized), and 1 small shared collection. I managed to get a split-brain in my change set stream last year and was quite proud when I stitched it back together. Been working fine ever since. Until…

After noticing that a bookmark wasn’t “taking”, I remembered I should have backed up promptly and was sad to see my backup helper was not running. This is unusual, it is an OSX account startup item for me. There were JSON files in the backups starting 12 days ago. The memex UI had become unresponsive and appeared to have no data as I looked around the new version. I did all of the following in some order:

  • navigate to old UI and back
  • navigate to the backup page which showed a spinner
  • determine the spinner was because the helper was not running
  • start the helper
  • login using the link at the bottom left of the plugin settings page
  • let it run for 15 minutes
  • observed it appeared to catch up on backups and the newest backup file stopped growing, but there was still a spinner on the backup page. debugger indicated no activity.
  • was able to view the plugin dashboard page
  • it is clear that my recent bookmarks, notes, and tags are there and I can scroll back in time
  • however, I have no collections
  • I am also not logged on to memex again
  • I also took snapshots of my backups at several points during the above, as well as snapshots of my chrome CPU profile in the debugger, and even snapshots of my entire chrome profile folder.
  • sync in the upper right corner of the dashboard indicates I should login
  • Decided to come here for advice. An hour has passed. Still no collections. Would not be the end of the world if I lost collections, a bigger bummer would be holes in my time series of pages. Should I do something about the missing collections prior to logging on to attempt a sync?

Thanks,

Ethan

(assuing this forum soft will ping my email when there’'s an update here…)

Hey Ethan,

Sorry to hear this.

if you want we can hop on a call trying to solve it.
I can now within the next 30-45min.
Otherwise would tomorrow 10am CET or 6pm CET work for you?

Good is that It looks like nothing serious in the sense of data loss.

Since my last update, Memex seems to have exhibited the behavior described by a famous Microsoft support doc: “things that happen by themselves can also go away by themselves”. I had to reboot my laptop and when my Chromium came back up, Memex looks like nothing ever happened - aside from the new version being installed. The collections are back. It has the pink flash prompts to do the migration for online sync. The backup tab on the settings page is loading, and shows a recent backup. I took another snapshot of the backups (looks like the data has not changed) and pressed the sync button.

Waiting now as it is obviously working hard on something…

The popup indicating migration in progress initially said “don’t interrupt this, or you have to start over”. Now it says “You can close this modal.”, although it is clearly still working. Pressing the close button…

image


(I’ve been cutoff from further replies to myself…)

OK, new problem: the # of sync events is not going down, and I’m getting ~2 JS errors per second from the memex plugin. It appears it cannot load firebase-messaging-sw.js.

My guess is that Chromium is blocking that, as is this is “ungoogled chromium” (https://github.com/Eloston/ungoogled-chromium) which has stoppers at several layers to keep data from leaking to Google. However, I don’t think it simply breaks every firebase webapp. For example, The Bitwarden browser plugin works and I know it uses GCM. Investigating…


Update 3

All is well. The 7800+ changes were stuck not syncing until they weren’t.

The firebase-messaging-sw.js is a red herring? I still see those errors about twice per second, but it seems to be a side-effect of chrome devtools being open. I see that -sw exists, embedded in background.js, and some combo of devtools / ungoogled chromium can’t handle it.

Oli, feel free to delete or move all this junk I posted on your thread.

I’m still not sure what the moral of the story is. At each point, I waited at least an hour, while it seemed like nothing was happening. Then at some point later the software magically works. It might be to not only wait an hour plus, but restart your browser periodically? That is one thing I didn’t do.

Hi there,

Hope you’re all doing well. All of a sudden I am not able to sync anymore and it won’t even allow me to log in using my usual credentials. The wheel just keeps turning. All of my collections and tags disappeared. I use Mozilla Firefox as a browser.

Any help appreciated

Thanks

This has been solved via email support. For anyone experiencing this too, try to restart the extension (not uninstalling it) by going to chrome://extensions or about:addons (firefox).