Help needed: Sync experienced a timeout

I’m using Opera browser on macOS. And I have Memex app on Android. I’m logged in and I tried syncing my computer and mobile several times via the QR code. But I receive the following message every single time: sync experienced a timeout.

Is there anything I can do?

I am having exactly the same problem, syncing a device always ends in a timeout. I tried 3 different browsers (Chromium, Chrome, Firefox). I’m running Ubuntu. Tried uninstalling and reinstalling the app, but it didn’t work.

Hey folks!

sorry you’re running into issues. I can reproduce it on my end too.
Currently in a bit of a bind here.
We are only few weeks (~6) away from releasing the new multi-device sync (multiple browsers, mobile devices and also tablet support, and auto-cloud backup)
If we spend time investigating and fixing this now it’ll be obsolete really soon and would delay the new sync to launch, potentially quite significantly.

Would it be possible to wait a bit more on this?

1 Like

It’s ok, was just wondering why it isn’t working :slight_smile: Glad the problem isn’t only on my side. I can and will gladly wait!

1 Like

I’m glad to hear. I was just wondering if I was missing something. I can definitely wait.

Quick check in with you folks:
We are short before the release, scheduled for October 11.
From then on you can sync as many devices as you want, have auto-backup and saving and annotating stuff on tablets available.

Originally planned to release today but we have been running into some last hickups last week that felt too early to release today.

It ends up being 10 instead of 6 weeks.
Sorry about the miscalculation.

1 Like

Thanks for your reply :slight_smile: I’m excited about the sync functionality and can’t wait to be able to sync my devices again!

It’s done! Pushed to the Chrome and Firefox Store, but will still take a few hours to get through review.
It was a 350+ commit update, so it may have some delays.

Will send out a message to everyone as soon as the update went through!

Chrome webstore still at 2.19.2 as of Oct 12, afternoon, US MT. Still not through review or am I missing something?

Yes, still in review. I am frantically reloading the Chrome store page all day already.
Very annoying :sweat_smile:


It’s released now in Chrome. Firefox still awaits review of the last version. They every once in a while schedule a manual check, and are currently overloaded with 3-4 weeks wait time.
Hoping that with the 3.0.0 release it’s then as fast as when they do the automatic check, which is usually 15-30min.