Error 525 SSL handshake failed

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Firefox, MacOS 10.15

  2. Which version of Memex are you running?

  3. What are the steps you took that lead to the bug?
    Everytime that I click on a memex link redirecting to, I get an error 525 in my browser. it seems that something is wrong with that domain (url) so I cannot download the back up app, neither look at the tutorials, … your help/suggestions are highly appreciated.

Thanks for the note!

Should be fixed now. If not, can you provide specific url where it is (still) happening?

Thank you for your reply.
No, I still get the 525 errors. For instance:

this is really odd. it all works fine for me. What happens if you do a hard reload?

a hard reload does not help :slightly_frowning_face:
I tried other browsers (Safari, Edge). Same 525 error.
I tried other device (a mobile). Same error

problem solved now. :tada: