Console errors in Waterfox Classic and Current

To get your bug fixed faster please try to answer the following questions:

  1. Which browser, operating system and versions of those are you using?
    Manjaro Linux, Waterfox Classic and Current, latest patches (2020.07.01) with the newest Memex, hoping this would solve the problem (it didn’t)

  2. What are the steps you took that lead to the bug?
    Installing Memex on a blank profile leads to these console errors. Memex is completely broken - stuck spinning animations, links not working (pioneer upgrade link), no indexing or bookmarking features, etc.

I have seen similar screenshots from other browsers and I posted on a thread about Vivaldi. I don’t think this is a vivaldi specific issue as I’ve seen similar errors from people talking about Chrome, etc. For the record I have never had issues with any other Firefox extension although others have reported them in the past. I will reach out on their Reddit form to see what they say too. This is not a Linux issue as I can confirm it works on normal firefox and this wasn’t an interaction with any plugins because it was on a blank profile. I noticed as well that there were some graphical alignment issues with the splash intro in Waterfox (button going over the images) where in Firefox that was not the case.

I have had a frustrating experience trying to get up to speed with Memex but I really support what you are doing and will be donating soon in hopes that this will be fixed soon :slight_smile:

This is probably fixed with the latest release 2.4.0.

Try updating and see if it works for you.
Sorry for the troubles!

It’s actually not and I think it’s a Waterfox issue but it may spread some light on the similar issues that other browsers are having. I noticed I got some message about Polyfills and then realized that there had been Waterfox posts about Polyfill issues although they had supposedly been fixed.

I applied the fix listed here:

And this enabled Memex to work in Waterfox Current, have not yet tried on classic.

It looks like you could apply something like this to fix the problem for those who have broken globalThis support or no globalThis support:

Looks like this fix doesn’t work on Classic as violentmonkey will not run in extension windows. Might try to fork the code to add the globalthis I mentioned earlier to see if I can compile something that works for Waterfox classic and you’d have something to integrate for the next version.

Actually not sure how I got Violentmonkey to work on an extension at all. Just updated, haven’t had time to fork and fix this, would be great if this was rolled into the next release…I diagnosed the problem so this should be easy. Not sure why this was automatically flagged as solved when I didn’t confirm. @BlackForestBoi

Sorry, meant to tag it as “acknowledged”

Anyway, I am sorry we don’t really support Waterfox.
I tried my best here, but it seems as if its an issue on the side of Waterfox anyway?

Did you read that I diagnosed the problem? You’re using globalThis which isn’t supported the same cross browser. The console errors I’m getting look a lot like other random bugs I’ve seen pop in and out and on Vivaldi as well. Not using a shim/polyfill isn’t a “Waterfox” issue, it’s best practices in web development, and as these similar issues seem to randomly pop up it seems easy enough to add a shim. There’s no downside to this and it may help the people who keep reporting tons of console errors in different situations like I am.

I checked out the code and I saw in it’s admitted “2. Direct usages of window global object: may or may not be issue, depending on case, but I’m always confused when we’re meant to use things like this directly - making a decision and defining guidelines would be good.”

I am kind of disappointed by the kneejerk reaction to this issue “it’s a Waterfox thing”…no, you had the same issue on Vivaldi, and there were other bugs that could be caused by this…

It looks like the right place to put this would be browser-polyfill.js. Tried to add a globalThis fix myself but I’m having issues getting Memex to build at all for some reason which I haven’t figured out.

Sorry that you felt brushed off here.

Indeed I got a little bit too much on my plate right now and didn’t give it the right attention.

Reading over your responses a bit too fast I understood that it is an issue that only appears on Waterfox but it does not cause issues somewhere else. Pot. also still Vivaldi, but both browsers we don’t officially support atm. Therefore I couldn’t/can’t put effort on it right now, from a priority POV.

Really sorry. I wished we had more resources to not deprioritise requests like that.
Hopefully there soon.

I understand and I appreciate you taking another look! I know that you don’t support those browsers and there’s a trend well outside this project pushing web development towards including less in the polyfills and that’s separate than this project as well.

Still having local build issues myself, otherwise I’d try pushing a fix :confused: Going to try to see what’s wrong. Yarn seems to hang. I’ve never used yarn before so not sure what the problem is.

At what step do you run into issues.
Can you share a screenshot of any error that appears?