Archiving & Full Text Search Won't Work for 301 Redirected Page (e.g. Medium)

  1. Which browser, operating system and versions of those are you using?
  • Brave v1.10.93 Chromium v83.0.4103.106 (64-bit) (latest Official as of 19 June 2020).
  • macOS Catalina 10.15.5
  1. What are the steps you took that lead to the bug?
  • trigger archiving for Medium post e.g. this post
  • try searching for any full-word inside that post that is not part of title

Medium Rejects Archiving Request

I just know about the trick used by Medium to prevent archiving for their posts: Medium tries to prevent people reading deleted articles on the Wayback Machine? - HN thread - for linked site.

This method prevents archiving site like or

  • I tried archiving the afore mentioned Medium post using SingleFile, and publish it to my private archival site.
  • then I bookmarked both the original Medium post and the archived page on Memex 2.
  • at first, I search for the title.
  • both site listed on search result
  • I tried searching for the existing word “cereal
  • search result lists only my static archival site.

@BlackForestBoi I want to give information that I think this issue already fixed. I tried the test case (search ‘cereal’) and it works now.

maybe the 2.2.4 release fixed this?
Fix importer bugs that prevented some urls to be indexed

You can tag this issue as fixed now :smiley:

1 Like