Android update crashes

I have just updated the Memex Android App (Fairphone 4, Android 11). The app cannot be opened anymore, crashes immediately.

Did you automatically update it and did the app constantly update or did you do a big version jump?

We just updated to 1.8.15, lmk if the problem persists.

The problem is still there. A few weeks ago I had installed the latest version of Memex from the playstore. That version worked without any problems. A few days ago, I received a message in the playstore that there was an update available. I downloaded it and the process went without any problems. However, it is not possible to open the app. I get a white screen very briefly and then the app shuts down. Version 1.8.15 has the same problems.

Ok the first fix was just on a hunch on where the problem could be.

We could now reproduce it and fixed it with 1.8.16.
Just pushed it to the review and should be available soon.

Let me know if it works. Should be available in a couple of hours hopefully.

I have downloaded version 1.8.16. Unfortunately, the problem is still there. It is not possible to open the app. Again a white screen after which the app is closed immediately. (Fairphone 4, Android 11)

Ok we found new leads and are already working on a fix. Pushing an update asap.

Ok our latest attempt at a fix is pushed to Android and will be available in 1.8.17.
Will probably take a few hours.
Fingers crossed that it fixes it!

Congratulations, bingo! Good update, everything works fine :grinning: :upside_down_face: :grinning:

Had the same issue for a few days and just wanted to mention that it is fixed now also for me. Thanks for the update!

Unfortunately, I cheered too early. The app now starts up and seems to synchronise well. However, when I try to open a saved article, the app crashes.

When you say “try to open a saved article” you mean in the dashboard you click on a result to open it in the annotation viewer?

Yes, the articles in my spaces don’t open and result in crashing the app. I have again downloaded the latest update. A new problem has appeared. I can no longer log in with my user name and password. I have tested it on my laptop, there is no problem with my login details in the chrome extension.

We can reproduce the issue and our devs are on it!

1 Like

I have performed the latest update and everything seems to be working fine: I can log in again, synchronisation went smoothly and I can open the articles in my spaces. Good job!

1 Like

Great, just came here to update you on that :slight_smile:

Besides that what we are working on the mobile app as we speak and next up is:

  1. Adding annotations to individual spaces & changing their privacy status
  2. Adding a second share-extension button for directly jumping to the annotation viewer. So you’ll have one “Quick Save” that gets you to the current share modal and one “Annotate” that gets you straight into the annotation viewer
  3. Being able to share Space links, page links and annotation links from within the app to other apps via the OS ‘share-to’ interfaces