Addressbar: m + blank does not switch to Memex-Search in Firefox

Trying to search Memex from the address bar does not work in Firefox.
Operating-Systems: Windows 10 and OSX.
Firefox: 72.02 and Memex 1.5.3

Reproduce: Start Firefox and type m + blank, nothing happens.

Tested in Chrome, works like described.

Thanks for your help.

Hey @strandundmeer

Welcome to the community forums and thanks for making us aware of a problem!

Firefox unfortunately really badly implemented that feature where extensions can define their own activation and search patterns.
Unlike in Chrome, the search results do not show the memex icon, but that green puzzle piece. It also does not switch the indicator in the search bar to this, but just keeps showing the "m " in the address bar.

Essentially you just need to continue typing and it will show you the results like this:

Hope that helped!

Thanks @BlackForestBoi,

you’re right. I tried it and it worked the way you described it.
Perhaps you could manage to add memex as a search engine, then switching using one or two characters should work.


thats unfortunately also not possible, because the search engines you can add there are effectively just URL schemas, not a direct implementation with the browser api. :frowning: