Memex stops adding pages to colletions and assigning tags

Steps to reproduce:

  1. Open any page, for example
  2. Press Memex icon in the toolbar
  3. Press Add to collection and choose collection
    Actual result:
    Collection title blinked in Add to collection field but nothing happened
  4. Go back and try to assign a tag
    Actual result:
    The same behavior, tag is no assigned

Firefox Nightly 90.0a1 (2021-05-12) (64-bit)
MacOS Catalina 10.15.7 (19H1030)

Got the same problem with Memex 2.19.1 on Firefox 89.0 (64 bits) with Windows 10 Pro 19043.985 (21H1), adding that even the search features doesn’t give any result. Before the addon became stuck like that, it seemed to work for some minutes after intallation, as I was able to add an article in a collection.

I would like to mention, that I have tried to reinstall the add-on, but got the same result.

That is really weird. Do you folks see anything when you open this in your browsers address bar: about:devtools-toolbox?type=extension& > console
Can you make a screenshot?

Also after you made the screenshot, disable and enable the extension again and make another screenshot.

Don’t uninstall it without running a backup. Memex is offline first and you’ll lose all your data if you haven’t done a backup before.

Found the bug, fix will go out today!


Fixed with 2.19.3. Only affected Firefox users.

Thanks, everything works fine now. Do I understand correctly that you don’t need the screenshot anymore?